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RPV311 

Distributed Multifunction Fault Recorder  

Chapter 1: Introduction 
 

This chapter provides some general information about the technical manual and an 

introduction to the software tool described in this technical manual. 
 

 Foreword 
This technical manual provides a functional description of GE Reason DR Manager 

software tool, as well as a comprehensive set of instructions for using it. The level at 

which this manual is written assumes that you are already familiar with protection, 

automation and control engineering and have experience in this discipline. The 

description of principles and theory is limited to that which is necessary to understand 

the product. 

We have attempted to make this manual as accurate, comprehensive and user-friendly 

as possible. However, we cannot guarantee that it is free from errors. Nor can we state 

that it cannot be improved. We would therefore be very pleased to hear from you if you 

discover any errors, or have any suggestions for improvement. Our policy is to provide 

the information necessary to help you safely specify, engineer, install, commission, 

maintain, and eventually dispose of this product. We consider that this manual provides 

the necessary information, but if you consider that more details are needed, please 

contact us. 

All feedback should be sent to our contact center via the following URL: 

http://www.gegridsolutions.com/alstomenergy/grid/grid/contactcentre 
 

1.1 Target Audience 
This manual is aimed towards all professionals charged with installing, commissioning, 

maintaining, troubleshooting, or operating any of the products within the specified 

product range. This includes installation and commissioning personnel as well as 

engineers who will be responsible for operating the product. 

The level at which this manual is written assumes that installation and commissioning 

engineers have knowledge of handling electronic equipment. Also, system and 

protection engineers have a thorough knowledge of protection systems and associated 

equipment. 
 
 

 

 Key Features 
 

http://www.gegridsolutions.com/alstomenergy/grid/grid/contactcentre
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The DR Manager is a Windows based software tool, used for communication via 

Ethernet with GE Reason Digital Recorders (RPV311 and DR60). The DR Manager is 

capable of downloading COMTRADE files from both RPV311 and DR60. Additionally, the 

DR Manager provides alarm monitoring, e-mail alarming, automatic TW fault location 

and device settings configuration for the RPV311 only.  

The DR Manager shall be installed in a computer running MS Windows and connected 

to the same Ethernet network as GE Reason digital recorders. 
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Chapter 2: DR Manager 
 

 

 Requirements 
The DR Manager Installer works on Microsoft Windows and needs .NET 4 (client profile) 

to run. It also depends on the database engine PostgreSQL 9.3, which is installed by the 

installation wizard. The user must run the installer as administrator for the complete 

installation to be allowed. The software is supported on Windows 7 and 10. 

This manual refers to DR Manager version 09A00. 

 Installation 

2.1 Procedures 
 

Below are described instructions to install Reason DR Manager in Windows 7 

Operational System: 

1. First ensure that 5432 port is enabled on the network that Computer is 

connected (this information is obtained from the network administrators); 

2. The installer must be run from a user who has administrator privileges (is not 

possible to run Wizard in a shared or remote drive); 

3. Run installer always from C:/ directory. If Hard Drive is partitioned and the file 

is in another partition, it is recommended always run it from C:/ for correct 

installation. Installation Files should be extracted to C:/ and not on a mapped 

drive or another shared drive (when it has another hard drive). 

4. In some cases, it may be necessary to adjust the installer compatibility to 

Windows 7: “Run this program in compatibility mode for: Windows 7”. After 

changing compatibility, the installation window will open normally. 

 

By double-clicking on “ReasonDRManager.InstallerWizard.exe” the following message is 

shown requesting to run the application with administrator privileges:  

 
Figure 1 - Run as administrator information. 

 

After running the application as an administrator, the Installation wizard will appear. 

Follow the installation sequence as described on the installation screen. 
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Note: To install DR Manager 08A00 version is necessary first to uninstall RPV 
Manager 07A00 version. Click “3 – Uninstall RPV Manager” as described in the 
following figure. 

 

 
Figure 2 – Reason DR Manager Installer 08A00 information with pre-installed RPV 
Manager 07A00 version. 

 

After uninstalling RPV Manager 07A00 is necessary to update “Database Data” as shown 

on figure below before installing the software Reason DR Manager 08A00 version: 

 
Figure 3 – Reason DR Manager Installer information. 

 

Then is possible to install Reason DR Manager. The next figures indicate that operation: 
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Figure 4 – Reason DR Manager Installation procedures. 

 

All downloaded records will be located at folder configured in “Configuration -> Polling -

> COMTRADE Directory and Select Directory”.  

Software logs will be at “Reason DR Manager -> logs” folder. 

 

2.2 Plugins Management 
The installation of the RPV311 plugins is performed by the following menu: 

“Tools -> Plugins Management -> New Install”. The plugins are necessary to perform 

offline configuration using the RPV311 Configuration Tool (Tools>Configuration Tools). 

An example of plugin is “rpv311-software.plugin.install-en-13X05.exe”. After doing 

correctly Plugin installation, the installed plugins will be shown in Tools>Plugins 

Management. 

 

Note 1: The DR Manager only supports RPV311 with firmware version 13A02 or 
newer.  

Note 2: Reason DR Manager will export RPV311 configurations on any desired 
folder, but importation of settings to RPV311 using DR Manager will only work if 
the files are located in DR Manager installation folder, namely “C:\Reason DR 
Manager\conf” directory. 

 

 Software Description 

3.1 DR Manager Main Window 



 

9 DRManager-TM-EN-2.2 

 

3.1.1.1 System Monitor 

 

Figure 5 – DR Manager main window. 

The software main tab is called System Monitor. All the substation and RPV311 

configured in the software are listed in a tree menu on the left corner of the window. 

The top level of the tree shows the user created facilities and the equipment installation 

on the second level. 

After clicking on the device with the left mouse button, the equipment records will be 

loaded and displayed in tabs depending on the type of record selected (Fault, 

Disturbance, Traveling Wave, Steady-State or Sequence of Events). This information is 

updated after a Refresh. 

By right-clicking on the equipment, the user can update the State of the equipment, 

through the option "Refresh", or access the equipment web configuration page, 

through the option "Access Web Configuration". 

The records highlighted in yellow are stored only in equipment memory which can be 

seen each time a Refresh occurs. 

Green highlight represents the records that have already been downloaded and then 

saved in the database in the respective directory including data of the equipment within 

the COMTRADE directory.  

If communication is lost with the equipment, only records in green will be displayed. 

Download of records can be done automatically or manually. In the manual case either 

a few selected records or all records can be downloaded.  

 

 

Figure 6 – Downloaded records. 

Note: In software version DR Manager 08A00 and later, only the RPV311 
connection and alarms are monitored by the Alarm tab and Tools>Alarm. The 
DR60 alarms and connection are not monitored by the DR Manager. 

 



DR Manager  

 

10 DRManager-TM-EN-2.2 

 

3.1.1.2 Alarms 
 

Alarms tab shows all registered equipment alarms, including information of "Time 

Quality" and "firmware version". 

 

 

Figure 7 – Alarms tab. 

There are four background colors, as described below: 

 

Color Description 

White Communication not yet established with the 
equipment 

Yellow Alarm(s) active 

Green No alarms 

Orange Communication lost with the equipment 

 

The user can check details on the alarms and their states by clicking the equipment’s 

name. 

3.1.1.3 Auto Polling 
 

With the Auto Polling tab the user can check the number of files that have been 

downloaded and the number of files waiting to be downloaded. 

When active, the software will check which records have not yet been saved and will 

download them. Records will only be downloaded automatically from equipment with 

Auto Polling enabled. 

A background color indicates that the equipment is being checked.  

During the download, the data is updated on the screen as the records are transferred. 
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3.1.1.4 Download Modes 
 

• Automatic download:  

 
The procedure to activate the Auto Polling can be seen in the Settings Menu 3.2.1.1. 

 

• Manual Download:  

 

Selected records:  

Select the records required and click the button “Get Selected”; 

 

All records:  

Click "Get All". 

 

Double click on the downloaded record to open (it is necessary to have a software to 

open .zic files already installed). 

To close this window use the close button in the top right, or use File >Exit.  

A confirmation message will be shown after closing. 

3.2 DR Manager Settings 
DR Manager presents some settings that user can access through the menu bar. These 

settings are shown below. 

3.2.1 File Menu 
In the File menu, the user can: 

• Open COMTRADE folder: 

The Open containing folder option will open the default register's downloaded folder. 

By default, the folder is C:\RPV\Records. 

 

• Import COMTRADE Records: 

This option allows the user to import COMTRADE files that were not downloaded by the 

DR Manager and add them to the DR Manager data basis so it is possible to see and 

open the COMTRADE files using the DR Manager interface and also run the TW Fault 

Location on the tw COMTRADE files. 

 

• Back up Data 

This option will export the DR Manager data basis so it is possible to restore it in the 

future without the necessity to configure all the Installations and Devices over again. 

The backup will contain all user settings (Installations, Devices, Transmission Lines, 

Contacts and Warnings) and the COMTRADE file list visible on the user interface. The 

COMTRADE files are not part of the backup. 

 

• Restore from Backup 

This option uses the backup file created on the Back up Data option (described above) 

to restore one or both following options: 
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▪ All Data: Restore all the data basis, i.e., settings and file lists. 

▪ Settings: Restores only the settings (Installation, Devices, Transmission 

Lines, Contacts and Warnings) so the user does not have to configure the 

DR Manager in another computer.  

 

• Refresh All Devices. 

▪ Refresh the list with COMTRADE files (but does not download them); 

▪ Refresh Alarms tab;  

▪ Send e-mail when new alarms exist;  

▪ Compares the local configuration file with the respective RPV311 

configuration file. 

 

• Close the software with the "Exit" option. 

 

3.2.1.1 Settings Menu 
In the Settings menu, the user can: 

• Create, edit and remove Installations; 

• Create and remove Devices; 

• Configure Transmission line for TW fault location; 

• Create, edit and remove contacts for e-mail sending; 

• Create, edit and remove Warnings to be sent. 

 

Signing up RPVs to the DR Manager: 

The DR Manager sorts the devices in the follow manner: 

First, it is necessary to create what is called Installation, that can be, for example, the 

substation where RPV311 is installed. Then the user shall register the RPV311 and 

assign each of them to an installation by creating what is called Device. 

Below mentioned is the procedure to create Installations and Devices. 

3.2.1.2 Creating Installations 
The process to create a new Installation is: 

1. Click <SETTINGS> menu and then click <INSTALLATIONS>; 

2. Click <NEW> to create. Type the Installation's name and description and then 

press <OK>. 

The user can view the list of registered substations and add, edit, or remove a 

substation. Substations can only be removed without any equipment being associated. 

 

3.2.1.3 Creating Devices 
 

The user can view the list of registered equipment, add, edit, or remove some 

equipment. Equipment can only be removed when there is no transmission line 

associated and if the Auto Polling is disabled.  

 

The process to create a new device is: 

• Click <SETTINGS> menu and then click <DEVICES>; 
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• Click <NEW> to create; 

• At <HOST>, type equipment's IP address; 

• Choose the model of the device: RPV or DR60; 

• Choose device installation in the Installation list; 

• Add the username and password for the device; 

• Click at <Get Info> and then press <Ok>; 

 

The figure below shows the Device configuration window. 

 

 

Figure 8 – Device window. 

On this screen two parameters can be configured by the user: 

 

Enable Auto COMTRADE Download: When enabled, the unit will be part of the Auto 

Polling process, where records not yet saved are automatically downloaded.  

Enable Auto Refreshing: When enabled, the unit will be part of the process of Auto 

Refresh, where the equipment state will be updated automatically during the process.  

 

The user can change the equipment host address, and enable or disable the "Enable 

Auto COMTRADE Download" and "Enable Auto Refreshing". At the end of the editing, 

the software automatically communicates with the equipment to upgrade the name 

and location information.  

If the equipment is associated with any transmission, a message will be shown to the 

user at the beginning of the Edit: 
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Figure 9 – Device associated to Transmission Line message. 

Note: For COMTRADE downloading, the DR60 uses File Transfer Protocol (FTP RFC959) and 
the RPV311 uses SSH Secure Shell protocol. 

 

Note: Reason DR Manager will export RPV311 configurations on any desired folder, but 
importation of settings to RPV311 using DR Manager will only work if the files are located in 
DR Manager installation folder, namely “C:\Reason DR Manager\conf” directory. 

 

Note: For DR60 and DRmanager integration allowed users are cfg or adm t. 

 

Note: To confirm compatibility in between DR60 and DRmanager, please check the release 
notes for the versions you are using. 

DR60 firmware version 02A04.1 and above shall be compatible to DRmanager version 9.2.6 
and above. 

 

3.2.1.4 Transmission Lines (Automatic Fault Location) 
The transmission line window configures the parameters necessary to execute the 

Traveling Wave Fault Location algorithm on the TW high acquisition frequency records.  

 

On this menu user can view the list of the registered lines, add, edit, or remove any 

transmission line. 
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Figure 10 – Transmission Line configuration. 

In order to add and edit a transmission line, the user must: 

1. Select the installation A at one terminal of the line; 

2. Select the device A that is monitoring the line in installation A; 

3. Select the installation B at the other terminal of the line; 

4. Select the device B that is monitoring the line in installation B; 

5. The field Section is used to select how many sections the line has, i.e. how 

many different propagation constants K (used when the line has overhead an 

underground sections) 

6. Enter the line lengths and K for each section of the line. Refer to Chapter 7 TW 

Fault Location in RPV311 Technical Manual for further information on the 

constant K. 

7. Enter the Threshold used in the TWFL Basic method. Refer to 3.3 Automatic 

TW Fault Location for further information. 

8. Enter the names of the Current Circuits A and B. As it is configured in the 

RPV311, figure below. These circuit names are used to identify the correct 

Fault waveform used in the Advanced TWFL Method. Refer to TW Fault 

Location Methods 3.3.2.1 for more information. 
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Figure 11 – Current Circuit name. 

9. Enter the names for the terminals A and B. As configured on the TW screen in 

the RPV311, see below. 

 

Figure 12 – Terminal name configuration. 

10. Finally, enter the name of the transmission line. 

 

The field ID shows the ID of the transmission when monitoring through MODBUS the 

result of a fault location. Further information in 3.3 Automatic TW Fault Location. 

 

Note: Although DRmanager allows the user to configure more than one line with 
the same parameters “Installation”, “Device A”, “Device B”, “Terminal A” and 
“Terminal B”, it doesn’t support automatic fault location for more than one line per 
combination of terminal. Please consider that when planning your Travelling 
Waves Fault Location system.  
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3.2.1.5 Contacts 
This menu configures the contacts to which DR Manager can send e-mails notifications. 

On this window the user can view the list of registered contacts, add, edit, or remove 

any contact. During the removal of any contact, if any association with any warning, a 

confirmation message will be displayed to the user. 

 

3.2.1.6 Warnings 
On this screen the user can view the list of warnings, add, edit or remove any warning. 

By setting the warning the user can select which contact will receive the alarms. It is 

possible to configure which events will make the DR Manager send warning e-mail, 

according to the following settings: 

 

Figure 13 – Warning menu. 

Send e-mail when monitored RPV311 have active alarms, when a fault is found in the 

COMTRADE files. In case a fault has been identified it is possible to attach the 

COMTRADE file of that fault to the e-mail. 

 

3.2.2 Polling Menu 
In the Polling menu, the user can: 

• Select software polling to be manual; 

• Select software polling to be automatic. 

In the manual mode, both the Refresh of the COMTRADE list and the download of 

records must be commanded by the user. 

In the automatic mode, the software will download the records and refresh the 

COMTRADE list automatically according to the parameters set on the 

Configuration>Polling menu. Also, each device must have that option enabled on the 

Settings>Device menu. 

3.2.3 Tools Menu 
 

In the Tools menu, the user can: 



DR Manager  

 

18 DRManager-TM-EN-2.2 

 

 

Figure 14 - Tools menu. 

• View software alarms and alarms history; 

• Calculate Traveling Wave fault location manually; 

• Execute the GOOSE Configurator, which configures RPV311 GOOSE 

communication. Refer to Chapter 12, Section 1.5 in RPV311 technical manual; 

• Execute the RPV311 Configuration tool and manage the software plugins; 

• View records history; 

• Search for records (with date filter); 

• View records report. 

3.2.3.1 Software Alarms and history 
The Alarm window shows active alarms and the alarm history. 

The Active Alarms tab displays the alarms still on. Examples of these alarms are: 

Equipment not Ready, Slot or Enlace Problem, Equipment not sync, primary power not 

found and communication error. The History tab displays alarms that came back to off 

state. 

The list is updated by the Refresh command. 

;; 

3.2.3.2 Traveling Waves fault location 
 

To locate the fault in the transmission line using the Traveling Wave method, the user 

must: 

1. Select the transmission line, enabling the other fields for editing; 

2. Select the COMTRADE TW files of both terminals of the line. Note that when 

you select the Transmission Line, the directory selection window will open 

directly in the record folder in C:\RPV\records; 

3. Click Locate to run the algorithm and locate the fault.  
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3.2.3.3 GOOSE Configurator 
 

This option opens the GOOSE Configurator software described in Chapter 12, Section 

1.5 in RPV311 technical manual. The GOOSE configuration software is responsible for 

the association of the SCL file of the sending IED with the RPV311 GOOSE inputs. 

 

3.2.4 Configuration Tool 
 

This option open the Configuration Tool described in Chapter 12, section 1.3 in RPV311 

technical manual. This software is responsible for the management of the several 

RPV311 configurations and offline configuration. 

Note: The Configuration Tool access through the DR Manager works only with 
firmware versions from 13A02 onwards. To manage firmware versions before that, 
the RPV Tools (Chapter 12 RPV Tools should be used. 

 

3.2.4.1 Plugins Management 

 

This menu is used to install the plugins that the Configuration Tool mentioned above 

uses to work with offline configurations. Each firmware version requires a separate 

plugin to work offline. 

 

3.2.4.2 View Records History 
 

In this option the user can view the records download history, sort by download date, 

by registry and by duration time. 

The maximum number of records displayed is configured in the option Display 

Downloaded COMTRADES Limit on the Polling configuration window. 

3.2.4.3 Search for records 

 

In this option user can use filters to search for specific downloaded records of a selected 

DFR. 

The search can be made taking into account: 

▪ Selection of one or more equipment; 

▪ Period start and/or end of the occurrence of the registry; 

▪ Reason of occurrence; 

▪ Record type: 

▪ All (this will get all types of records); 

▪ Fault recorder: records of short duration, with two advanced search options: 

Triggered and Continuous; 
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▪ Disturbance recorder: records, with two advanced search options: Triggered 

and Continuous; 

▪ Travelling Wave recorder: records of travelling wave; 

▪ Steady-state: measuring records continues with four advanced search options: 

Average series, Harmonics, Flicker PST and PLT; 

▪ SOE: records of sequence of events. 

 

3.2.4.4 Records Report 
 

This menu displays a chart with the percentage number of each kind of register 

downloaded. 

To view the chart, you must select a period, select a device and click the button 

"Report". That will display the graph showing the percentages of each type of record. 

Hover the mouse cursor over the graph to see the number of records saved, as shown 

in the figure below: 

 

Figure 15 – Percentage of records chart. 

 

It is possible for certain periods to have no downloaded files available so no graph will 

be loaded on the interface. 

 

3.2.5 Configuration Menu 
 

In the Configuration menu, the user can: 

• Configure software polling; 

• Configure the coefficients used in TW calculation; 

• Configure e-mail; 

• Choose which Browser will be used to open the Configuration Tool. 
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3.2.5.1 Polling 
On the Polling Configuration menu, the user can configure the COMTRADE polling, 

refresh and storage of files. The Figure below shows the Polling configuration window. 

 

 

Figure 16 – Polling configuration. 

Polling Configuration fields description: 

COMTRADE Directory: directory path where the new records are downloaded and 

where the fault locator calculation searches; 

Display Downloaded COMTRADES Limit: maximum COMTRADE records already 

downloaded that will be displayed on the screen; 

Display Available COMTRADE Age (day): limit, in days, of downloaded records that will 

be fetched and displayed on the screen; 

COMTRADE DAT File: format in which the COMTRADE file will be saved; 

Start Auto Polling on Init: starts Auto Polling automatically by the application; 

Automatic Fault Location: performs the fault location calculation after the COMTRADE 

file refresh; 

Auto Refresh Interval (min): interval, in minutes, that an automatic update of the data 

of the device will run when the Auto Polling is active; 

Auto COMTRADE Polling Interval (min): interval, in minutes, that will be held the 

automatic download of COMTRADE files; 

Auto Polling COMTRADE Age (day): maximum age, in days, of records that will be 

downloaded automatically in Auto Polling. For example, if a register was made 5 days 

ago and the DR Manager is started today and the Auto Polling COMTRADE Age (day) is 

set to 4 (or 1, 2 or 3) the register will not be downloaded during the auto polling; 

Equipment Request Limit: limit of records that will be requested from the equipment in 

each query; 

Retrieve Fault: When selected, automatically downloads the short duration records, 

both triggered and continuous; 
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Retrieve Disturbance: When selected, performs the automatic download of the slower 

disturbance records, both triggered and continuous; 

Retrieve Travelling Wave (TW): When selected, performs the automatic download of 

the travelling wave records; 

Retrieve Steady State (SS): When selected, performs the automatic download of the 

continuous measurement records; 

Retrieve Sequence of Events (SOE): When selected, performs the automatic download 

of the sequence of events records. 

 

If modification on this windows is made, a message will be displayed asking the user to 

restart the program.  

3.2.5.2 Coefficients 
The TW fault location algorithm uses a few coefficients during the fault location 

process. The DR Manager default coefficients shall not be altered unless advised by GE 

Grid Solutions. 

3.2.5.3 E-mail 
Allows the configuration of the e-mail account that the DR Manager will use to send e-

mails. 

3.2.5.4 Browser 
This option allows the user to choose which Browser will be used to open the 

Configuration Tool. The MS Internet Explorer and the Mozilla Firefox are supported. 

3.2.6 Help Menu 
 

• About 

The About screen shows information on the software such as: software version, 

copyright and memory usage. 

 

3.3 Automatic TW Fault Location 
DR Manager features an automatic TW fault location capability, where the DR Manager 

automatically downloads the COMTRADE registers from both line ends, calculates the 

fault location, displays it on the software interface and make it available via Ethernet 

MODBUS. 

3.3.1.1 Description 
After the fault location calculations are performed, the distance to fault is displayed on 

the software interface and it is made available via MODBUS communication according 

to the MODBUS IDs of the Transmission Line configuration menu and the IP address 

configured in the windows Ethernet properties of the DR Manager computer. 

 

MODBUS Fault Location Transmission 
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Whenever a TW fault location is performed the DR Manager will provide three separate 

16-bit MODBUS registers. The registers are described below: 

 

Description MODBUS Observation 

Register_1 30001 

MODBUS identifier visualized on the Transmission Line 
menu used to identify which transmission line the current 
fault location refers to. The identifier in chosen 
automatically by the DR Manager and cannot be configured. 

Register_2 30002 
As the fault location is split into 2x16-bit register. This 
register carries the LSBs (least significant bits) of the 32-bit 
register. 

Register_3 30003 
Second part of the fault location. This register carries the 
MSBs (most significant bits) of the 32-bit register. 

 

In order to achieve the actual fault location, it is necessary to combine the 2 fault 

location registers (30002 and 30003) into a single 32-bit value. The register 30003 is a 

decimal representation of the 16 most significant bits of the complete 32-bit register 

which contains the fault location and the register 30002 is a decimal representation of 

the 16 least significant bits of the 32-bit register. The combination of them will result in 

the actual fault location in meters.  

Below is the necessary operation to combine both fault location registers: 

 

Actual fault location in meters = ((Register_2 & 0XFFFF) | (Register_3 << 16)) 

 

When consecutives fault locations are found for the same line, the DR Manager will 

display all the fault locations as list. And these locations are going to be sent via 

MODBUS with a 1-minute time interval between them. 

3.3.2 Switch-on to Fault 
 

When a short circuit occurs right after the circuit breaker closes, the behavior of the 

traveling waves become different from regular faults, mainly because the circuit 

breaker itself can create traveling waves that can be misinterpreted as traveling wave 

from the fault and it may turn the fault location calculation more difficult. To avoid that, 

the DR Manager analyses both the waveform/fault and the TW COMTRADE records to 

first identify that a switch-on event occurred and then to apply a special fault location 

algorithm. Additionally, special conditions need to be met for the switch-on to fault 

(SOTF) events to be located automatically: 

 

▪ The fault shall be at least 6 km away from both line terminals. 

▪ The transmission line maximum length shall be 2000 km. 

▪ The fault location for switch-on events will not work for mixed (hybrid) lines. 

▪ There needs to be a corresponding waveform recording for each event (Error! R

eference source not found.. Error! Reference source not found.. Error! 

Reference source not found.). 

 

Even meeting all the conditions above, SOTF events are rare and difficult to interpret 

automatically, thus, the DR Manager will indicate on its interface whenever an event is 

characterized as a switch-on so the user can be cautious and double check the 

recordings. 
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3.3.2.1 TW Fault Location Methods 
 

The DR Manager uses two calculation methods for TW fault location. They are called 

“Basic” and “Advanced”. The method used for each calculation is identified on the DR 

Manager interface, as shown in Figure 17. The two methods are described below:  

• Basic Method 

 

Uses a threshold configured on the Transmission Line menu, which is a percentage 

value of the full scale of the register, to identify the beginning of the traveling wave 

created by the fault and, consequently, to find its timestamp in order to use in TWFL 

calculations. This method uses only the high frequency COMTRADE files acquired by the 

RA333 units to locate the fault. 

 

• Advanced Method 

 

This method uses both the fault records (waveform at 50/60Hz) and the TW records 

(high frequency register) to identify the fault location. The fault record is analyzed using 

a high-pass filter in order to find the time window that contains the fault beginning, 

then that time window is used in the TW record to enhance the location of the correct 

time stamp for the fault. As the time window to track the fault waveform in narrow 

down using this method, various system noises are eliminated from the calculations 

increasing significantly the chances to automatically find the fault. 

 

Figure 17 – DR Manager TWFL methods. 

3.4 Polling and Refresh 

3.4.1.1 Refresh 
 

The equipment refresh option performs the following actions: 

• Update of the list of records on the main screen; 

• Updating the status of the equipment; 
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• Update of Alarms (Alarms tab); 

• Verification of alarms for sending e-mail; 

• Check the settings (local and remote). 

 
This refresh may occur in the following situations: 

• "Refresh" option from the equipment menu, access by right clicking on the 

substations equipment tree in the System Monitor. This option will update the 

data of the selected equipment; 

• "Refresh All Devices", access through the File menu. This option will update all 

registered equipment; 

• "Auto Refresh". This option will update only the information of configured 

equipment. 

 
To configure the Auto Refresh:  

1. For each device, the box Enable Auto Refresh on the Settings>Device menu;  

2. To set the update interval change the field "Auto Refresh Interval " on the 

Configuration>Polling menu; 

3. To activate or deactivate the Auto Refresh, access the Polling menu and 

choose between Manual or Auto options; 

4. To ensure that the software starts with the Auto Refresh option active, check 

the box "Auto Polling on Initiation" on the Configuration>Polling menu; 

The refresh action also happens during the: 

 

• Start of application execution; 

• Change in list of substations; 

• Change in the equipment list. 

 
After communication with the equipment, the software checks if any information was 

changed and updates the information as follows: 

• Interface: System Monitor equipment tree tab and equipment lists in the 

other tabs; 

• Database; 

• Information of the Transmission Line configurations for each device; 

• Name of the directory where the new records will be downloaded. 

 

3.4.1.2 Polling 
 

The polling routine is responsible for performing the automatic download of records 

from each equipment. 

Configure the Auto Polling as follows:  
1. For each equipment with desired Auto Polling functionality, "Enable Auto 

COMTRADE Download " should be enabled in Device settings; 

2. To set the update interval, the field "Auto Polling Interval" must be changed in 

the Polling configuration screen; 
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3. To activate or deactivate the Auto Polling, access the menu Polling Auto, to 

activate, and Polling > Manual, to disable; 

4. To ensure that the software starts with the Auto Polling option active, select 

the field "Auto Polling on Initiation" on the Polling configuration screen; 

5. COMTRADES records will only be downloaded that are younger than the 

period entered in the field “Polling COMTRADE Acts ", in Polling configuration 

screen; 

6. Only the types of COMTRADE records configured through the fields "Retrieve 

..."  in the Polling configuration screen of will be downloaded; 

7. To run the fault location algorithm automatically after downloading a 

COMTRADE record, select the field "Automatic Fault Location", in Polling 

configuration screen; 

8. Once everything is configured, the records will be downloaded to the directory 

"COMTRADE Directory "/Records. 

 

When the Auto Polling is set to on it will run during the following occasion: 

1. At system start up; 

2. When closing the Device window. 

 

Enable Automatic Polling by clicking the menu Polling>Auto; 

If the Auto Polling is active, each time interval is set in "Auto Polling COMTRADE Interval 

". 

If the execution time of the Polling process exceeds the polling interval configured, the 

next polling process will be ignored until the pending execution ends. 
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